Hello There, Guest! Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RRE opens server list
#1
I registered to my first race (CR1 at Imola, today at 15:00 CET) and when JOIN button appeared, I pressed it.
SteamVR loaded, then the game, but I landed in multiplayer section with list of servers. There was no server with Imola track listed.
I don't know if it makes difference, but I was only one registered to this race.
with regards
Reply
#2
(08-25-2018, 01:20 PM)Michal Kozusznik Wrote:  I registered to my first race (CR1 at Imola, today at 15:00 CET) and when JOIN button appeared, I pressed it.
SteamVR loaded, then the game, but I landed in multiplayer section with list of servers. There was no server with Imola track listed.
I don't know if it makes difference, but I was only one registered to this race.
with regards

Even if you were alone, you should have been able to connect to the server, a few questions:
1) You have just been put in the multiplayer page with the servers list, no red bar on the top with some kind of error message?
2) When you pressed "Join" on the app, did Steam opened a small window, playing a notification sound, where you had to click OK to continue? If not that would be weird
3) Most important one: was SteamVR already running when you tried to join, or was it closed and it opened up automatically when you pressed the OK button? I had issues when SteamVR was on while trying to join a race, so I make sure it's well closed before even opening the SRS app, then I have the option that makes it open automatically when needed. This way (and having the command line for VR in my user CP of course) I'm able to join races in R3E using VR without any problem

If you already do that, and you followed the instructions correctly (content detection off, updated version of the app...), then you will have to wait for admin help
Reply
#3
(08-25-2018, 02:07 PM)Lorenzo Andalò Wrote:  
(08-25-2018, 01:20 PM)Michal Kozusznik Wrote:  I registered to my first race (CR1 at Imola, today at 15:00 CET) and when JOIN button appeared, I pressed it.
SteamVR loaded, then the game, but I landed in multiplayer section with list of servers. There was no server with Imola track listed.
I don't know if it makes difference, but I was only one registered to this race.
with regards

Even if you were alone, you should have been able to connect to the server, a few questions:
1) You have just been put in the multiplayer page with the servers list, no red bar on the top with some kind of error message?
2) When you pressed "Join" on the app, did Steam opened a small window, playing a notification sound, where you had to click OK to continue? If not that would be weird
3) Most important one: was SteamVR already running when you tried to join, or was it closed and it opened up automatically when you pressed the OK button? I had issues when SteamVR was on while trying to join a race, so I make sure it's well closed before even opening the SRS app, then I have the option that makes it open automatically when needed. This way (and having the command line for VR in my user CP of course) I'm able to join races in R3E using VR without any problem

If you already do that, and you followed the instructions correctly (content detection off, updated version of the app...), then you will have to wait for admin help

Thanks for quick answer.
1. Haven't seen any error message. But it's easy to miss something while juggling with VR
2. yes. I had to confirm the Steam asked for confirmation to run the game.
3. In this attempt SteamVR was disabled. Because the game was being called with -vr parameter configured in SRS profile, it initialized SteamVR

You are saying you have problems with R3E while SteamVR is already running? I found, that if I run the game without SteamVR but with -vr parameter (like SRS does), after quitting the game, Steam indicates the game is running until I close SteamVR. So I decided to remove -vr parameter from SRS profile. Instead of this I have this in steam launch options and start SteamVR prior to R3E. It works well to me so far. One inconvenience with this solution is, that Steam asks you to confirm starting the game inside VR. On monitor there is no any indication about need of confirming anything. It also asks if I really want to run the game in desktop mode. But at the end R3E runs in VR.

However trying various options I lost another SRS race (pity there is no some test server)
This time I accidentally did run the game without VR mode. The game had connected to the server but I had to quit to run it in VR mode. Unfortunately reconnecting was unsuccessful. This time the game shown the main menu only. Not even entered server list.

Just a thought: couldn't be that "-vr monitor" options string (without quotes) is responsible for connecting the server?
Reply
#4
OK, I'm tired.
I'm just trying 3rd race, and it ends in the game main menu. No even attempt to go to multiplayer.
I've read that I can be banned for 2 days if not attending to race I registered to. But I've got no information I'm already suspended.
Reply
#5
Don't worry about the ban, if you clicked the join button, SRS considered you in the race even if you never made it to the server, as I told you, I had issues as well, and never got banned for app/game problems... proof is you can still register for races, if you were banned, you just couldn't
Now, I can try to tell you my settings: in Steam, I got nothing in the launch parameters for the game window, you don't need it anymore, when I practice I launch the game using the SteamVR option, if you still got launch parameters, delete them; now open SteamVR and right click on it to get on the settings, in the "developer" section there should be something like "Start SteamVR when you start an application", make sure you got that checked; now in the SRS website, click on your name next to Log out, and on your user CP, under edit profile, I got my "RRE cmd" set to -vr 2.0, use the numbers you feel confident with or none (just -vr)
Now close everything for good, like you just started your PC, open just Steam (NOT SteamVR, never click on it!), then the SRS app, register and join once again... you shouldn't even see SteamVR launching, that is gonna happen in the background... like I said SteamVR seams to interfere with the SRS app somehow, this are the only stable settings I found to join SRS races; if this is going to work remember, when you finish a race and want to join the next one, to always close SteamVR first!
If after doing everything like I said, is still not working, then it's probably not something about VR launching, and you gonna need to double check the instructions for the app and make sure you did everything right (check carefully, might be something very small and stupid, from the correct username in the edit profile on SRS to the correct folder where you unzipped the downloaded app)
Reply
#6
Thank you for your help and encouraging words.
I'll try your suggestions.
with regards.
Reply
#7
Finally I managed all those issues.

The 1st reported one was related to missing content. In particular I had no Imola track. I had no idea that this track is not a part of European Track pack I bought especially to get Imola.. lol.. My fault then.

Starting SRS with VR is kinda creepy. It should work without passing any params from SRS. The game is able to recognize availability of VR.
But in our case defining -vr parameter in SRS profile is indeed mandatory. I don't know why. If I try to do it a way I thing it should work, the game loads (in VR mode) but ends up in game menu (no even going to MP mode). There is a quote from SRS app instructions:

Quote:If you need to run RRE with command line parameters, like -vr etc.. Please insert them on the "RRE cmd" edit box bellow content detection and delete them on steam.
It says: "if you need". But in fact I don't need -vr since the game runs in VR mode once SteamVR is running.
My guess is the game gets no arguments for connecting dedicated server. I would like SRS devs to comment on this issue. To me it seems to be SRS or RRE related bug.

There is also something strange with VR resolution. If I define -vr parameter in SRS profile, the game starts with some serious subsampling. My quess is 0.25. Any one has idea why? I have to explicitly define super-sampling, so have to set -vr 1.0 in launch parameter in SRS.

Again, please devs look at this. It might be an issue with SRS app which passes improper arguments to RRE.

with regards.
Reply
#8
Yes, you are right, the SRS app was made before SteamVR implementation for the main game, so now you can launch the game from Steam just using SteamVR, but the app still launch it in the old way, so you still need the launch parameter line for VR in the SRS profile... regarding the resolution, before SteamVR update, if u didn't insert any number, the default one was loaded (1.4?), so I guess that now, after the update, since the resolution is normally decided by SteamVR, you always need to insert the value you desire...
In the end yes, the issue is the app outdated regarding the VR option implemented by the main game, we'll need to do things the "old school" way untill the app receives a massive update (and I'm not a programmer, but that sounds like a lot of work to me)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)